Illustrator for Lasercutting

In the Mekano we use Adobe Illustrator to prepare files for the lasercutter.

You can use any vector drawing program, but in the Mekano you can only send files to the lasercutter from Illustrator. Illustrator is also ideal to check your file and make sure it meets all the requirements for obtaining good results. Hereby we show you some things that are important to make a file for lasercutting.

Start with a new file in Illustrator, 700x400mm for the Trotec or 900x600mm for the Epilog lasercutter — 'Landscape' format and not 'Portrait'. Make sure that the color mode is RGB and not CMYK.

All lines and shapes have to be in 'outline' or 'stroke' and no 'fill'.

Cut lines must be in RGB red -> R:255 - G:0 - B:0 and line thickness must be 0,001 pt or mm.

Engraving lines must be in RGB blue -> R:0 - G:0 - B:255 and line thickness must be 0,001 pt or mm.

Black text, logo's, thicker lines and such can be raster engraved. Watch out because this takes a lot longer and you are better off to experiment first and see the result and the time it takes.

Black text, logo's and 'fat' lines must be in RGB black -> R:0 - G:0 - B:0.

Keep away at least 5mm from the edge of the page with all cutting and engraving shapes.

Take away all unnecessary stuff, including clipping masks. Only what needs to be cut or engraved should remain in your drawing.

Common errors

Are you using a later version of Illustrator then CS6?

Always save your file as a CS5 file.

Save as → Version: → Choose Illustrator CS5

You can’t set your lines to the right color?

First check whether your file has been setup in RGB and not CMYK.

File → Document color mode → choose RGB color mode

If your file was setup in CMYK, choose RGB and follow the steps below.

Select All (Control + a) → Edit → Edit Colors → Convert to RGB

Now you can set the lines to the correct color.

Lines are not visible on your screen with width set to 0,001 mm (Illustrator CC)

Edit → Preferences → GPU Performance → Untick GPU Performance

You want to join multiple plates?

Because you have to stay 5mm from the edge, best practice to join multiple plates, is to make a frame at 5 mm from the edge. In this frame you can make your design.


Clipping masks occur when converting your file to Illustrator?

Use the script you can download here.

Paste this script in the following folder:

C:\Program Files\Adobe\Adobe Illustrator CC 2015\Presets\en_GB\Scripts

Restart Illustrator.

You can select this script here:

File → Scripts → RemoveClippingMasks

The laser cutter stops immediately after pushing the start button.

Possible causes:

  • The line width is not correct
  • Opacity is not 100% → Select all the lines and set 'opacity' to 100%.


Blue lines (engraving) are being cut (Epilog).

When you only use blue lines (engraving), it is necessary to put a red line somewhere in your design. This is due to a bug in the software. This red line can be very small.

9867